Suchen

 


 

BAR Fern-Assistenz

 
 
 
Erstellung

PHP 5.6

 

Der Support von PHP 5.4 wurde eingestellt, auf allen unseren Hostserver ist daher PHP 5.6 installiert.
Wenn Sie PHP Scripts oder Applikationen verwenden, so sollten Sie in jedem Fall eine aktuelle Version haben, die mit PHP 5.6 kompatibel ist.

Bei den folgenden Anwendungen muss zumindest die gelistete Version vorhanden sein:

  • FinishWeb alle Versionen
  • WordPress 4.0
  • Drupal 7
  • Typo3 6.2
  • Joomla 3.1
  • Mediawiki 1.22.1

Was ist bei PHP 5.6 neu
PHP 5.6 ist weitgehend kompatibel zu PHP 5.4, mit Ausnahme der folgenden Funktionen:

  • Array-Schlüssel werden nicht mehr überschrieben, wenn man ein Array mit einem Array-Literal als Eigenschaft einer Klasse definiert.
  • Die Funktion json_decode ist strikter beim Parsen der JSON-Syntax.
  • Die Stream-Wrapper verifizieren jetzt standardmässig die Zertifikate und Hostnamen der Kommunikationspartner, wenn TLS verwendet wird.
  • GMP-Ressourcen sind nun Objekte.
  • Mcrypt-Funktionen verlangen gültige Schlüssel und Initialisierungsvektoren.

Die kompletten Infos finden Sie auf der PHP-Seite.

Was muss ich tun
Stellen Sie bitte sicher, dass Ihre PHP Scripts und Applikationen PHP 5.6 tauglich sind:

  • Kontrollieren Sie vorher Versions-Nummern bekannter Applikationen
  • Fragen Sie Ihren Webmaster
  • Kontrollieren Sie ob Ihre Scripts und Applikationen korrekt funktionieren


Eigenschaften ID: 000262   Ansichten: 2370   Aktualisiert: vor 5 Jahren
Abgelegt unter: