Suchen

 


 

BAR Fern-Assistenz

 
 
 
Erstellung

PHP 5.4

 

Der Support von PHP 5.3 und auch PHP 5.4 wurde eingestellt. Daher laufen alle unsere Webserver unter PHP 5.6.

Die folgenden Hinweise zum Upgrade von 5.3 auf 5.4 sind daher nicht mehr aktuell.
Bitte beachten Sie den Supportartikel zu PHP 5.6.

 

 

Wenn Sie PHP Scripts oder Applikationen verwenden, so sollten Sie in jedem Falle eine aktuelle Version haben, die mit PHP 5.4 kompatibel ist.

Bei den folgenden Anwendungen muss zumindest die gelistete Version vorhanden sein.

  • FinishWeb alle Versionen in Ordnung
  • WordPress 3.6
  • Drupal 6
  • Typo3 6.1
  • Joomla 2.5 / 3.1
  • Mediawiki 1.21.1

Was muss ich tun?

Stellen Sie bitte sicher, dass Ihre PHP Scripts und Applikationen PHP 5.4 tauglich sind.

  • Kontrollieren Sie Versions-Nummern bekannter Applikationen
  • Fragen Sie Ihren Webmaster
  • Kontrollieren Sie am 25. September, ob Ihre Scripts und Applikationen korrekt funktionieren

Was ist bei PHP 5.4 neu?

  • traits
  • Kurze Syntax-Arrays wie z.B. $sa [1, 3, 6];
  • Anonyme Funktionen unterstützen $this
  • Class Member Zugriff auf Instanzen z.B. (new Foo)->bar()
  • Binäre Zahlen
  • Session-Extension kann den aktuellen Stand eines Dateiuploads verfolgen
  • Besseres Fehler-Verhalten und bessere Inkompatibilitäts-Meldungen

Die kompletten Infos finden Sie auf der PHP-Seite.

Was geht bei PHP 5.4 nicht mehr?

Einige Funktionen waren bereits unter PHP 5.3 als veraltet (deprecated) gekennzeichnet. Diese Funktionen wurden in PHP 5.4 nun deaktiviert.

  • Kein Safe Mode mehr
  • Keine Magic Quotes mehr
  • Keine „register_globals“ und „register_log_arrays“ mehr


Eigenschaften ID: 000249   Ansichten: 2713   Aktualisiert: vor 5 Jahren
Abgelegt unter: